備忘録 a record of inner life

やったことや考えたこと・本・論文・音楽の備忘録。 特に環境科学・生態毒性に関して。

アセンブラFlyeのインストール

この記事(MaSuRCAのインストールエラー)の続き。

今度はCanuよりも評判が良いFlyeをインストール。MaSuRCAで苦しんだのでBiocondaでインストールしようとするも、Flyeはpython 2.7に依存しているがUbuntuにはpython 3.7を入れているのでコンフリクトエラーでインストールできず。

conda install -c bioconda -y flye

上のコマンドに対して下のようなエラー。

Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: \
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

- flye -> python[version='2.7.*|>=2.7,<2.8.0a0']

If python is on the left-most side of the chain, that's the version you've asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Your current python version
is (python=3.7). Note that conda will not change your python version to a different minor version
unless you explicitly specify that.

The following specifications were found to be incompatible with each other:

 

Package setuptools conflicts for:
python=3.7 -> pip -> setuptools
flye -> python=2.7 -> pip -> setuptools
Package wheel conflicts for:
python=3.7 -> pip -> wheel
flye -> python=2.7 -> pip -> wheel
Package pip conflicts for:
flye -> python=2.7 -> pip
python=3.7 -> pip
Package ca-certificates conflicts for:
python=3.7 -> openssl[version='>=1.1.1a,<1.1.2a'] -> ca-certificates
flye -> python=2.7 -> ca-certificates
Package certifi conflicts for:
flye -> python=2.7 -> pip -> setuptools -> certifi[version='>=2016.09']
python=3.7 -> pip -> setuptools -> certifi[version='>=2016.09']

 

Python - pythonのバージョンが上げられません|teratail

 

このページを頼りに、仮想環境を作るとインストールできました。

conda create -n py27 python=2.7 anaconda

conda activate py27

conda install -c bioconda -y flye